Game in developement

Incident Report for Bloxy Cafe

Investigating

Game release delayed
Posted Feb 24, 2023 - 09:21 UTC

Monitoring

Game is in developement and will release this week.
Posted Feb 15, 2023 - 21:51 UTC
This incident affects: Cafe game.